<
From version < 18.1 >
edited by Vincent Massol
on 2016/03/02
To version < 18.2 >
edited by Eduard Moraru
on 2016/03/09
>
Change comment: There is no comment for this version

Summary

Details

Page properties
Author
... ... @@ -1,1 +1,1 @@
1 -XWiki.VincentMassol
1 +XWiki.enygma
Content
... ... @@ -196,12 +196,13 @@
196 196  {{html clean='false'}}
197 197  <!-- For Mouseflow -->
198 198  <script type="text/javascript">
199 - var mfq = mfq || [];
200 - (function() {
199 + var mfq = mfq || [];
200 + // Depend on the jQuery loaded by RequireJS so that we mouseflow does not load its own jQuery version, breaking require code that depends on a diferent jQuery version/instance.
201 + require(["jquery"], function() {
201 201   var mf = document.createElement("script");
202 202   mf.type = "text/javascript"; mf.async = true;
203 203   mf.src = "//cdn.mouseflow.com/projects/72d20ebd-a6f8-48f6-b211-3cf36eadb0ee.js";
204 204   document.getElementsByTagName("head")[0].appendChild(mf);
205 - })();
206 + });
206 206  </script>
207 207  {{/html}}
Cannot make recursive include